Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 2
Registered: ‎10-13-2015

Re: Response returning empty

[ Edited ]

I am also having this issue. Our environment did not chage, however we are recieving an empty response in sandbox mode. RIght now SSL verify peer is set to true, posting to https://apitest.authorize.net/xml/v1/request.api. If i set verify peer to false it works. But why on Friday did this just stop? Any ideas?

Member
Posts: 7
Registered: ‎10-13-2015

Re: Response returning empty

[ Edited ]

We are having the same issue. Our page errors out because the response is empty. What can we do to fix this ASAP?

 

Our test in the sandbox works perfectly fine, but our live clients are having issues.

Member
Posts: 7
Registered: ‎10-13-2015

Re: Response returning empty

Any word from Authorize.NET on this? This is a HUGE issue for us since it just started happening and is affecting PAYING clients.

Posts: 2,765
Topics: 57
Kudos: 270
Blog Posts: 67
Registered: ‎12-05-2011

Re: Response returning empty

We're monitoring this thread but so far we're unable to duplicate the problem.  No changes were made to our systems during this time period.

 

Can you connect to the domain from that server, using anything? What about traceroute?  Were any modules updated on your system which could have effected the connection?

Member
Posts: 9
Registered: ‎02-22-2012

Re: Response returning empty

When using the sandbox account I get this below. When switching back to the live a.net account it starts working.

 

 

SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Member
Posts: 6
Registered: ‎10-12-2015

Re: Response returning empty

@RichardH I have the same situation as @mepting0235

 

We are using the php-sdk from github: https://github.com/AuthorizeNet/sdk-php

 

In sandbox mode whenever trying to communicate with Authorize we receive this response:

 

SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed

 

 

No changes were made to our system, this just stopped working on Friday the 9th

 

Is there an updated pem file that we need to use or should the one in the git repo be good?

Member
Posts: 5
Registered: ‎10-13-2015

Re: Response returning empty

Just downloaded PHP SDK from https://github.com/AuthorizeNet/sdk-php. It seems AIM is working fine. But when tried CIM (AuthorizeNetCIM) it is not working. Showing curl error "SSL certificate problem: unable to get local issuer certificate".

 

FYI : In both cases "AUTHORIZENET_SANDBOX" was set to true

 

Hope this helps!

Highlighted
Member
Posts: 9
Registered: ‎02-22-2012

Re: Response returning empty

The AIM is working, but the ARB is not working for us. Thanks!

Member
Posts: 3
Registered: ‎10-14-2015

Re: Response returning empty

[ Edited ]

Same problem here. Seems it has been appeared last week. The AIM requests is working, but the CIM requests and TD requests return empty responses. Problem is only in sandbox mode.

Posts: 2,765
Topics: 57
Kudos: 270
Blog Posts: 67
Registered: ‎12-05-2011

Re: Response returning empty

When you are using the SDK, are you use the original methods or the new controller model?