Reply
Member
Posts: 7
Registered: ‎10-13-2015

Re: Response returning empty

We changed NOTHING on our side. It has been working as is for several years without any issues. 

Administrator
Posts: 591
Registered: ‎08-21-2009

Re: Response returning empty

We're continuing to try and look into this on our side, but to this point we have been unable to recreate or identify any problems. The issues being reported here all seem to center around connections to https://apitest.authorize.net, but the certificate that we have installed currently active on that domain is the same certificate that has been on that domain for the better part of the past 4 months.

 

At this time, I'm asking anyone experiencing the error to provide us platform details that may help identify a trend. Specifically, we are looking for any of the following information:

  • Development language (PHP, Java, C#, etc..)
  • Development language/platform version. (PHP 5.3.0, .Net 4.6, etc)
  • Operating System (Windows server 2012, Ubuntu Server 15.10, etc.)
  • Curl version  (if applicable)
  • Authorize.Net SDK in use (if any)

We will continue to look into this as much as we can.

Member
Posts: 3
Registered: ‎10-14-2015

Re: Response returning empty

Here my configurations

  • Development language - PHP
  • Development language/platform version - PHP 5.4.3
  • Operating System - Windows 7
  • Curl version - 7.25.0
  • Authorize.Net SDK in use - Version 1.1.8 (not newest, maybe, but it works great in our live platform).

Have problems with responses when call

$request = new AuthorizeNetTD($auth_keys->api_login_id, $auth_keys->transaction_key);
$request->setSandbox($this->config->item('authorizenet_sandbox'));
$auth_response = $request->getTransactionDetails($transaction_id);

 

and 

 

$customerProfile = new AuthorizeNetCustomer;
$customerProfile->description = $this->input->post('cart_id');
$customerProfile->email = $record['email'];
// Add payment profile
$paymentProfile = new AuthorizeNetPaymentProfile;
$paymentProfile->customerType = "individual";
$paymentProfile->payment->creditCard->cardNumber = $multiPayment['x_card_num'];
$paymentProfile->payment->creditCard->expirationDate = $multiPayment['x_exp_month'].$multiPayment['x_exp_year'];
$paymentProfile->payment->creditCard->cardCode = $multiPayment['x_card_code'];
$paymentProfile->billTo->firstName = $multiPayment['x_first_name'];
$paymentProfile->billTo->lastName = $multiPayment['x_last_name'];
$paymentProfile->billTo->address = $multiPayment['x_address'];
$paymentProfile->billTo->city = $multiPayment['x_city'];
$paymentProfile->billTo->state = $x_state_code;
$paymentProfile->billTo->country = $x_country_code;
$paymentProfile->billTo->zip = $multiPayment['x_zip'];
$customerProfile->paymentProfiles[] = $paymentProfile;

$response2 = $request->createCustomerProfile($customerProfile, $this->config->item('CIM_validation_mode'));

Member
Posts: 5
Registered: ‎10-13-2015

Re: Response returning empty

Here my configurations
Development language - PHP
Development language/platform version - PHP 5.5.15
Operating System - Windows 7 / Windows 8
Curl version - 7.36.0
Authorize.Net SDK in use - Version 1.8.4 / 1.8

 

define("AUTHORIZENET_API_LOGIN_ID", "YOURLOGIN");
define("AUTHORIZENET_TRANSACTION_KEY", "YOURKEY");
define("AUTHORIZENET_SANDBOX", true);

$request = new AuthorizeNetCIM; // Create new customer profile $customerProfile = new AuthorizeNetCustomer; $customerProfile->description = "Description of customer"; $customerProfile->merchantCustomerId = time(); $customerProfile->email = "test@domain.com"; $response = $request->createCustomerProfile($customerProfile); if ($response->isOk()) { $customerProfileId = $response->getCustomerProfileId(); }
 

 

Highlighted
Member
Posts: 6
Registered: ‎02-13-2015

Re: Response returning empty

Here my configurations
Development language - java
Development language/platform version - java jdk1.7.0_40
Operating System - linux ubantu and redhat
Curl version - na
Authorize.Net SDK in use - anet-java-sdk-1.8.4-SNAPSHOT.jar  and  i tried with anet-java-sdk-1.8.6-SNAPSHOT.jar  too.

 

still facing same issue. 

 

Its really annoying authorize .net couldn`t fixed it since issue was reported 3 days ago and still collecting data. 

Member
Posts: 3
Registered: ‎10-14-2015

Re: Response returning empty

[ Edited ]

Same issue, developing for Java 1.8.0_60 on Windows Server 2012 R2 Standard with current anet-java-sdk.jar. Calls coming through Apache/Tomcat 8.0.20.

Member
Posts: 6
Registered: ‎10-12-2015

Re: Response returning empty

[ Edited ]

Development Language/Platform: PHP 5.5.15 on Apache

Operating System: FreeBSD 9.1-RELEASE-p13

Curl Version: 7.24

Authorize.Net SDK: https://github.com/AuthorizeNet/sdk-php using CIM

Contributor
Posts: 42
Registered: ‎09-26-2015

Re: Response returning empty

Here my configurations

 

  • Development language - Java / JSP
  • Development language/platform version - Java 1.8 / Tomcat 8
  • Operating System - Windows 7 and Lunix
  • Curl version - N/A
  • Authorize.Net SDK in use - Version 1.8.5

 

 

2015-10-14 16:00:01,905 INFO  [http-nio-80-exec-10] BSG               (CreditCardProc.java:52)     - credit card trans:
2015-10-14 16:00:01,905 INFO  [http-nio-80-exec-10] BSG               (CreditCardProc.java:53)     -   params: proc id: 1; type: VISA; account: 4111111111111111; auth code: ; amount: 70.0; security code: 390; resp msg: ; proc ref: ; Orig id: ; Ref id: 1000
2015-10-14 16:00:01,906 INFO  [http-nio-80-exec-10] BSG               (CreditCardProc.java:54)     -     resp:
2015-10-14 16:00:01,943 INFO  [http-nio-80-exec-10] util.HttpClient   (LogHelper.java:24)     - Use Proxy: 'false'
2015-10-14 16:00:02,127 DEBUG [http-nio-80-exec-10] conn.SingleClientConnManager (SingleClientConnManager.java:195)     - Get connection for route HttpRoute[{s}->https://test.authorize.net]
2015-10-14 16:00:02,407 DEBUG [http-nio-80-exec-10] protocol.RequestAddCookies (RequestAddCookies.java:131)     - CookieSpec selected: best-match
2015-10-14 16:00:02,428 DEBUG [http-nio-80-exec-10] client.DefaultHttpClient (DefaultRequestDirector.java:481)     - Attempt 1 to execute request
2015-10-14 16:00:02,428 DEBUG [http-nio-80-exec-10] conn.DefaultClientConnection (DefaultClientConnection.java:244)     - Sending request: POST /gateway/transact.dll HTTP/1.1
2015-10-14 16:00:02,428 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "POST /gateway/transact.dll HTTP/1.1[EOL]"
2015-10-14 16:00:02,430 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "Content-Type: application/x-www-form-urlencoded; charset=utf-8[EOL]"
2015-10-14 16:00:02,430 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "Content-Length: 270[EOL]"
2015-10-14 16:00:02,430 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "Host: test.authorize.net[EOL]"
2015-10-14 16:00:02,430 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "Connection: Keep-Alive[EOL]"
2015-10-14 16:00:02,430 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "User-Agent: Apache-HttpClient/4.0.1 (java 1.5)[EOL]"
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "Expect: 100-Continue[EOL]"
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "[EOL]"
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:248)     - >> POST /gateway/transact.dll HTTP/1.1
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> Content-Type: application/x-www-form-urlencoded; charset=utf-8
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> Content-Length: 270
2015-10-14 16:00:02,431 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> Host: test.authorize.net
2015-10-14 16:00:02,432 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> Connection: Keep-Alive
2015-10-14 16:00:02,432 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> User-Agent: Apache-HttpClient/4.0.1 (java 1.5)
2015-10-14 16:00:02,432 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:251)     - >> Expect: 100-Continue
2015-10-14 16:00:04,435 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - >> "x_tran_key=3x8vnRBpZ26Jr27X&x_allow_partial_Auth=FALSE&x_card_num=4111111111111111&x_method=CC&x_delim_data=TRUE&x_exp_date=32020&x_relay_response=FALSE&x_login=34k9PJz4&x_version=3.1&x_amount=70.00&x_test_request=FALSE&x_type=AUTH_CAPTURE&x_delim_char=%7C&x_encap_char="
2015-10-14 16:00:04,478 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - << "HTTP/1.1 100 Continue[EOL]"
2015-10-14 16:00:04,485 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - << "X-N: S[EOL]"
2015-10-14 16:00:04,485 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - << "Date: Wed, 14 Oct 2015 20:00:04 GMT[EOL]"
2015-10-14 16:00:04,485 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - << "Connection: keep-alive[EOL]"
2015-10-14 16:00:04,485 DEBUG [http-nio-80-exec-10] http.wire         (    Wire.java:78)     - << "[EOL]"
2015-10-14 16:00:04,487 DEBUG [http-nio-80-exec-10] conn.DefaultClientConnection (DefaultClientConnection.java:229)     - Receiving response: HTTP/1.1 100 Continue
2015-10-14 16:00:04,487 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:232)     - << HTTP/1.1 100 Continue
2015-10-14 16:00:04,487 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:235)     - << X-N: S
2015-10-14 16:00:04,487 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:235)     - << Date: Wed, 14 Oct 2015 20:00:04 GMT
2015-10-14 16:00:04,488 DEBUG [http-nio-80-exec-10] http.headers      (DefaultClientConnection.java:235)     - << Connection: keep-alive

Contributor
Posts: 42
Registered: ‎09-26-2015

Re: Response returning empty

 

It just worked for me....

 

 

 

2015-10-15 12:37:31,876 DEBUG [http-nio-80-exec-9] conn.SingleClientConnManager (SingleClientConnManager.java:195)     - Get connection for route HttpRoute[{s}->https://test.authorize.net]
2015-10-15 12:37:32,163 DEBUG [http-nio-80-exec-9] protocol.RequestAddCookies (RequestAddCookies.java:131)     - CookieSpec selected: best-match
2015-10-15 12:37:32,186 DEBUG [http-nio-80-exec-9] client.DefaultHttpClient (DefaultRequestDirector.java:481)     - Attempt 1 to execute request
2015-10-15 12:37:32,186 DEBUG [http-nio-80-exec-9] conn.DefaultClientConnection (DefaultClientConnection.java:244)     - Sending request: POST /gateway/transact.dll HTTP/1.1
2015-10-15 12:37:32,187 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "POST /gateway/transact.dll HTTP/1.1[EOL]"
2015-10-15 12:37:32,188 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "Content-Type: application/x-www-form-urlencoded; charset=utf-8[EOL]"
2015-10-15 12:37:32,188 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "Content-Length: 270[EOL]"
2015-10-15 12:37:32,188 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "Host: test.authorize.net[EOL]"
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "Connection: Keep-Alive[EOL]"
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "User-Agent: Apache-HttpClient/4.0.1 (java 1.5)[EOL]"
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "Expect: 100-Continue[EOL]"
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "[EOL]"
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:248)     - >> POST /gateway/transact.dll HTTP/1.1
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> Content-Type: application/x-www-form-urlencoded; charset=utf-8
2015-10-15 12:37:32,189 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> Content-Length: 270
2015-10-15 12:37:32,190 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> Host: test.authorize.net
2015-10-15 12:37:32,190 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> Connection: Keep-Alive
2015-10-15 12:37:32,190 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> User-Agent: Apache-HttpClient/4.0.1 (java 1.5)
2015-10-15 12:37:32,190 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:251)     - >> Expect: 100-Continue
2015-10-15 12:37:34,192 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - >> "x_tran_key=3x8vnRBpZ26Jr27X&x_allow_partial_Auth=FALSE&x_card_num=4111111111111111&x_method=CC&x_delim_data=TRUE&x_exp_date=32020&x_relay_response=FALSE&x_login=34k9PJz4&x_version=3.1&x_amount=70.00&x_test_request=FALSE&x_type=AUTH_CAPTURE&x_delim_char=%7C&x_encap_char="
2015-10-15 12:37:34,588 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "HTTP/1.1 200 OK[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Cache-Control: private, must-revalidate, max-age=0[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Content-Length: 186[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Content-Type: text/html[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Expires: Tue, 01 Jan 1980 00:00:00 GMT[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Server: Microsoft-IIS/7.5[EOL]"
2015-10-15 12:37:34,593 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "X-Powered-By: ASP.NET[EOL]"
2015-10-15 12:37:34,594 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "X-Cnection: close[EOL]"
2015-10-15 12:37:34,594 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Date: Thu, 15 Oct 2015 16:37:35 GMT[EOL]"
2015-10-15 12:37:34,594 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "Connection: keep-alive[EOL]"
2015-10-15 12:37:34,594 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "[EOL]"
2015-10-15 12:37:34,595 DEBUG [http-nio-80-exec-9] conn.DefaultClientConnection (DefaultClientConnection.java:229)     - Receiving response: HTTP/1.1 200 OK
2015-10-15 12:37:34,595 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:232)     - << HTTP/1.1 200 OK
2015-10-15 12:37:34,595 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Cache-Control: private, must-revalidate, max-age=0
2015-10-15 12:37:34,595 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Content-Length: 186
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Content-Type: text/html
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Expires: Tue, 01 Jan 1980 00:00:00 GMT
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Server: Microsoft-IIS/7.5
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << X-Powered-By: ASP.NET
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << X-Cnection: close
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Date: Thu, 15 Oct 2015 16:37:35 GMT
2015-10-15 12:37:34,596 DEBUG [http-nio-80-exec-9] http.headers      (DefaultClientConnection.java:235)     - << Connection: keep-alive
2015-10-15 12:37:34,602 DEBUG [http-nio-80-exec-9] client.DefaultHttpClient (DefaultRequestDirector.java:540)     - Connection can be kept alive indefinitely
2015-10-15 12:37:34,605 DEBUG [http-nio-80-exec-9] http.wire         (    Wire.java:78)     - << "1|1|1|This transaction has been approved.|HWT2EE|Y|2242152361|||70.00|CC|auth_capture||||||||||||||||||||||||||3A67C852E01A298C3DD57ACC118ED333||2|||||||||||XXXX1111|Visa||||||||||||||||"
2015-10-15 12:37:34,605 DEBUG [http-nio-80-exec-9] conn.SingleClientConnManager (SingleClientConnManager.java:250)     - Releasing connection org.apache.http.impl.conn.SingleClientConnManager$ConnAdapter@6a49fa49
2015-10-15 12:37:34,606 DEBUG [http-nio-80-exec-9] conn.DefaultClientConnection (DefaultClientConnection.java:141)     - Connection shut down

Contributor
Posts: 12
Registered: ‎10-15-2015

Re: Response returning empty

[ Edited ]

Configuration:

 

  • Java 1.7.0_51 / Tomcat 8
  • OSX 10.9.5
  • Authorize.Net SDK version 1.8.5

Log shows:

 

[INFO ][ttp-8085-4][net.authorize.util.HttpClient] Use Proxy: 'false'
[DEBUG][ttp-8085-4][org.apache.http.impl.conn.SingleClientConnManager] Get connection for route HttpRoute[{s}->https://apitest.authorize.net]
[DEBUG][ttp-8085-4][org.apache.http.client.protocol.RequestAddCookies] CookieSpec selected: best-match
[DEBUG][ttp-8085-4][org.apache.http.impl.client.DefaultHttpClient] Attempt 1 to execute request
[DEBUG][ttp-8085-4][org.apache.http.impl.conn.DefaultClientConnection] Sending request: POST /xml/v1/request.api HTTP/1.1
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "POST /xml/v1/request.api HTTP/1.1[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "Content-Type: text/xml; charset=utf-8[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "Content-Length: 928[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "Host: apitest.authorize.net[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "Connection: Keep-Alive[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "User-Agent: Apache-HttpClient/4.0.1 (java 1.5)[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "Expect: 100-Continue[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.headers] >> POST /xml/v1/request.api HTTP/1.1
[DEBUG][ttp-8085-4][org.apache.http.headers] >> Content-Type: text/xml; charset=utf-8
[DEBUG][ttp-8085-4][org.apache.http.headers] >> Content-Length: 928
[DEBUG][ttp-8085-4][org.apache.http.headers] >> Host: apitest.authorize.net
[DEBUG][ttp-8085-4][org.apache.http.headers] >> Connection: Keep-Alive
[DEBUG][ttp-8085-4][org.apache.http.headers] >> User-Agent: Apache-HttpClient/4.0.1 (java 1.5)
[DEBUG][ttp-8085-4][org.apache.http.headers] >> Expect: 100-Continue
[DEBUG][ttp-8085-4][org.apache.http.wire] >> "[REDACTED]"
[DEBUG][ttp-8085-4][org.apache.http.wire] << "HTTP/1.1 100 Continue[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] << "Date: Thu, 15 Oct 2015 18:57:26 GMT[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] << "Connection: keep-alive[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.wire] << "[EOL]"
[DEBUG][ttp-8085-4][org.apache.http.impl.conn.DefaultClientConnection] Receiving response: HTTP/1.1 100 Continue
[DEBUG][ttp-8085-4][org.apache.http.headers] << HTTP/1.1 100 Continue
[DEBUG][ttp-8085-4][org.apache.http.headers] << Date: Thu, 15 Oct 2015 18:57:26 GMT
[DEBUG][ttp-8085-4][org.apache.http.headers] << Connection: keep-alive

 

 

 

A Payment Profile actually gets created in the Sandbox, but at our end, we never get a reponse other than the 100 Continue.

 

Sure be great if you folks could get this fixed soon. 

 

Thanks