Reply
Highlighted
Contributor
Posts: 25
Registered: ‎05-30-2014

SIM Required Form Fields not Validated

Hi All,

 

I have a process that uses SIM. In the Authorize account I set up an assortment of fields to show, and made them all required. They appear on the pay form with a little star next to them. Looks correct. When testing I purposely left one blank to see if I would get a message that it has to be filled in. This did not happen!  After clicking my relay response process kicked in and I ended up back on my web site with the result being the transaction was declined.

 

Let me point out that this is on the live server but with Test Mode set to True.  And I used a test credit card.  Do you think this is why it didn't validate (test mode)?

 

Thanks!

KB

Highlighted
Posts: 2,765
Topics: 57
Kudos: 248
Blog Posts: 67
Registered: ‎12-05-2011

Re: SIM Required Form Fields not Validated

Hello @KB_developer 

 

Test cards will never work in production.  Test Mode in production is used primarily to confirm that your API Login and Transaction Key are correct.  Test Mode should never be used in the sandbox.

 

Richard

Highlighted
Contributor
Posts: 25
Registered: ‎05-30-2014

Re: SIM Required Form Fields not Validated

Thanks Richard.

 

Finding good documentation has been a challenge!

 

Just to point out what I have going on - live server but Test mode turned on  - and many times it has approved the test cards.  It was only the "no catching an unfilled required field" that I've been concerned with. I am ready to take it out of test mode, and wondering if that will "turn on" the validation.  I don't want to use a real card and incur an actual charge till I understand this point. Any thoughts?

 

Most appreciated!

Highlighted
Contributor
Posts: 25
Registered: ‎05-30-2014

Re: SIM Required Form Fields not Validated

What I am have is this form action:

 

     action="https://secure.authorize.net/gateway/transact.dll"   

 

and within the variables currently have this:

 

   <input type='hidden' name="x_relay_response" value="TRUE" />

Highlighted
Contributor
Posts: 25
Registered: ‎05-30-2014

Re: SIM Required Form Fields not Validated

 

oops, meant to show this variable:

 

   <input type='hidden' name="x_test_request" value="TRUE" /> 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: SIM Required Form Fields not Validated

Highlighted
Posts: 2,765
Topics: 57
Kudos: 248
Blog Posts: 67
Registered: ‎12-05-2011

Re: SIM Required Form Fields not Validated

I would recommending using the sandbox for your testing since it uses the same gateway code running in production, but does not include a connection to the payment network.

 

Richard

Highlighted
Contributor
Posts: 25
Registered: ‎05-30-2014

Re: SIM Required Form Fields not Validated

Hi

 

All the suggestions are greatly appreciated.

 

Let me ask this last one then - I am ready to "be live"  So if I just remove this line --

   "<input type='hidden' name="x_test_request" value="TRUE" /> "

 

and set the flag for not being in Test mode in the Authorize account....

 

is that I have to do?   Anything else?

 

Thanks!

KB