Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 3
Registered: ‎09-27-2011

SIM trouble error 13

I have been trying to intergrate the checkout on my site and i got the buttons on my site just fine, the problem is when i click on them it takes me to a white page that reads -

 

The following errors have occurred.

(13) The merchant login ID or password is invalid or the account is inactive.

 

I'm using the code given on the website, I'm wondering what im supposed to put in the line that says - // Include the SDK you downloaded in Step 2 - the sdk file downloaded containes quite a few things. I'm thinking this may be the reason i get the error page. 

 

any help is apreciated.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: SIM trouble error 13

Are you using the PHP code at https://developer.authorize.net/integration/fifteenminutes/php#hosted            ??

The (13) The .... error mean either

a)your merchant login ID or transactionKey is enter wrong.

$api_login_id = 'YOUR_API_LOGIN_ID';
$transaction_key = 'YOUR_TRANSACTION_KEY';

or b)you are using a production ID and key to the test server.

<form method='post' action="https://test.authorize.net/gateway/transact.dll">

need to change to post to https://secure.authorize.net/gateway/transact.dll

Member
Posts: 3
Registered: ‎09-27-2011

Re: SIM trouble error 13

Yes, i am using the php code given. The api login and key are in place. I have already changed the test to secure in the link and it made no difference.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: SIM trouble error 13

If it is a production loginID, Key and it posting to secure.authorize.net. Double check the loginID, Key, make sure there is no space between the quote('). And that no one accidentally change/regenerate the transaction Key.

Member
Posts: 3
Registered: ‎09-27-2011

Re: SIM trouble error 13

I checked again and re copied the code, no spaces, everything is correct, still the same problem.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: SIM trouble error 13

Sound like you will need to call support.

Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: SIM trouble error 13

Hi there,

 

The only reason you will get an error 13 is if you're posting to a test URL and you are using a production account. For test accounts you will need to use https://test.authorize.net/gateway/transact.dll and for production accounts it needs to be https://secure.authorize.net/gateway/transact.dll. Another reason is if you are using your login id instead of your API Login id and the last reason is if your account is inactive. Those are the only 3 possible reasons why you will get this error.

 

Thanks!

-Joy