Reply
Member
Posts: 9
Registered: ‎06-03-2014

Re: Sandbox down?

This is what our VPS runs.

 

Server Type: Apache/2.2.27 (Unix) mod_ssl/2.2.27 OpenSSL/1.0.1e-fips mod_bwlimited/1.4

Member
Posts: 5
Registered: ‎06-03-2014

Re: Sandbox down?

It's a vagrant box that says:

 

$ openssl version

OpenSSL 1.0.1f 6 Jan 2014

 

PHP reports the same version of ssl.  It's as far upgraded as a dist-upgrade and an apt-get update; apt-get upgrade will do on my vagrant VM.

Posts: 321
Topics: 5
Kudos: 37
Blog Posts: 5
Ideas: 0
Solutions: 26
Registered: ‎11-09-2011

Re: Sandbox down?

Thanks. We suspect at this point that it may be specific to OpenSSL and the SSL versions enabled in it.

Can you force OpenSSL to use SSL v3 or TLS 1.0?

--
"Move fast and break things," out. "Move carefully and fix what you break," in.
Member
Posts: 5
Registered: ‎06-03-2014

Re: Sandbox down?

I'm honestly not sure how to go about doing that... any tips for an ubuntu/debian environment running apache/php?

Contributor
Posts: 12
Registered: ‎06-03-2014

Re: Sandbox down?

Is this issue going to impact the live Authorize.net at some point?  Our production server is using OpenSSL 1.0.1e-fips

Member
Posts: 5
Registered: ‎06-03-2014

Re: SSL Timeout Connecting to Sandbox

Hello, I'm having the same issue as mentioned in this post. I contacted the support technicians and was directed here. I'd like to point out that I have three people here in this office, myself included, all running "OpenSSL 0.9.8y 5 Feb 2013". It worked just fine when I left, then this morning when everyone booted up their machines my two fellow workers could not send requests, however I could. I'm the only one who hasn't turned off their machine since then, and I can still send requests without the SSL error. No clue what's going on, any advise would be helpful. Seems to me like there's some sort of weird caching going on or something. 

Contributor
Posts: 12
Registered: ‎06-03-2014

Re: SSL Timeout Connecting to Sandbox

My co-developer upgraded his WAMP to OpenSSL/1.0.1g and the issue does not occur.

Member
Posts: 5
Registered: ‎06-03-2014

Re: SSL Timeout Connecting to Sandbox

I wish I could upgrade...

 

according to http://askubuntu.com/questions/449184/how-to-upgrade-openssl-1-0-1f-on-ubuntu-server-14-04 it looks like the 1.0.1f included in ubuntu 14.04 has been patched to fix the heartbleed bug, but still doesn't work with ADN

Contributor
Posts: 12
Registered: ‎06-03-2014

Re: SSL Timeout Connecting to Sandbox

I'm about to try to upgrade our production server to it (CentOS).  I'll let you know if I'm able to.

Member
Posts: 5
Registered: ‎06-03-2014

Re: SSL Timeout Connecting to Sandbox

OpenSSL/1.0.1g doesn't make any difference on OSX. Same exact error.