Reply
Member
Posts: 2
Registered: ‎09-15-2014
Accepted Solution

Sandbox - The merchant login ID or password is invalid or the account is inactive.

[ Edited ]

I am attempting to set up authorize.net as a payment gateway for the first time, integrating with webassist ecart 6.

 

I created a sandbox account and have added my api login id and transaction key,

 

I received an email form authorize.net saying my sandbox account was active.

 

Whenever I attempt to make a payment, using one of the test card accounts, the transaction fails.

 

The only message I get is "The merchant login ID or password is invalid or the account is inactive."

 

I have checked my settings, but the account seems to be active, and my api key and transaction key have been corredtly entered

 

I have toggled my account between test mode and live mode, still no joy, (it should be in test mode right) ?


Accepted Solutions
Highlighted
Solution
Accepted by topic author crush123
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Sandbox - The merchant login ID or password is invalid or the account is inactive.

The sandbox account should NOT be in test mode. There is no reason for it to be in testmode on a sandbox account.

 

It the ecart 6 using the sandbox server/url(test.authorize.net)  or the production server/url(secure.authorize.net)?

View solution in original post


All Replies
Highlighted
Solution
Accepted by topic author crush123
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Sandbox - The merchant login ID or password is invalid or the account is inactive.

The sandbox account should NOT be in test mode. There is no reason for it to be in testmode on a sandbox account.

 

It the ecart 6 using the sandbox server/url(test.authorize.net)  or the production server/url(secure.authorize.net)?

Member
Posts: 2
Registered: ‎09-15-2014

Re: Sandbox - The merchant login ID or password is invalid or the account is inactive.

ok, i have changed the test mode back to live mode

 

I checked though the pages created by ecart 6 and it was using the production server https://secure.authorize.net.

 

i have now changed this to the sandbox server and my transaction is successful.

 

many thanks for your help