Reply
New Member
Posts: 5
Registered: ‎01-14-2020
Accepted Solution

Sandbox Worked Lastnight, and is now failing

 

So last night I was able to get the following code to work. Fast forward to today and I'm working on payment profiles, go to run my end to end tests, and now this that's been working fails. I rotated my transaction keys an hour ago to no avail.

 

def init_app(self, flask_app):
        self.merchantAuth = apicontractsv1.merchantAuthenticationType()
        self.merchantAuth.name = flask_app.config['AUTHDOTNET_LOGIN_ID']
        self.merchantAuth.transactionKey = flask_app.config['AUTHDOTNET_TRANSACTION_KEY']
        self.validationMode = flask_app.config['AUTHDOTNET_VALIDATION_MODE']

def create_customer_profile(self, user: User):
        print(1)
        payment_profile = apicontractsv1.customerProfileType()
        payment_profile.email = user.email
        payment_profile.description = user.get_full_name()
        print(2)
        request = apicontractsv1.createCustomerProfileRequest()
        request.merchantAuthentication = self.merchantAuth
        request.payment_profile = payment_profile
        print(3)
        controller = apicontrollers.createCustomerProfileController(request)
        controller.execute()

        print(4)
        response = controller.getresponse()

It "prints" to 3 so is failing on the profile controller instantiation and outputs the following

 

 

 

(
  <authorizenet.apicontractsv1.CTD_ANON_36 object at 0x7f6ba607e1d0>, 
  <pyxb.utils.fac.Configuration object at 0x7f6ba607e710>, 
  [
    <pyxb.binding.basis.ElementContent object at 0x7f6ba607e748>, 
    <pyxb.binding.basis.ElementContent object at 0x7f6ba607e780>
  ],
{})

The call to create_customer_profile is wrapped in a try ... except block, and nothing is getting raised from the SDK even in a blanket except: statement

 


Accepted Solutions
Solution
Accepted by topic author Yetzederixx
‎01-16-2020 07:22 AM
New Member
Posts: 5
Registered: ‎01-14-2020

Re: Sandbox Worked Lastnight, and is now failing

So the problem was me being lazy. I used VS Code to refactor a variable name and it was too aggressive, bleh.

View solution in original post


All Replies
New Member
Posts: 5
Registered: ‎01-14-2020

Re: Sandbox Worked Lastnight, and is now failing

I'm working on Ubuntu 18.04 and apparently TLS 1.3

Was some switch flipped last night perhaps?

Solution
Accepted by topic author Yetzederixx
‎01-16-2020 07:22 AM
New Member
Posts: 5
Registered: ‎01-14-2020

Re: Sandbox Worked Lastnight, and is now failing

So the problem was me being lazy. I used VS Code to refactor a variable name and it was too aggressive, bleh.