Reply
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Silent Post Issue after changing URL

Sound like there is an issue with the relay response page.

You could just just the silent post page as it use the same process on authorize.net end. just set the x_relay_url to your silent post url.

Highlighted
Solution
Accepted by topic author ChanceND
‎08-21-2015 01:58 AM
Contributor
Posts: 10
Registered: ‎12-10-2013

Re: Silent Post Issue after changing URL

Figured out my original issue after trying various things I found in other forum posts.

 

To get the two payment forms to work with the silent post URL on the new server I just had to add this to the Page setting of the page that was submitted to authorize.net

 

enableViewStateMac="false"

 

Must be related to the .NET Frameworks.  The old silent post URL was .net 2.0 and the new server its on is 4.0.  The two sites that did not work after switching the silent post page to 4.0 were also 4.0.