Reply
Highlighted
Member
Posts: 2
Registered: ‎04-25-2013

Silent Post URL Not Working

Hi,

 

I've been trying to get the silent post URL working, and I'm not having much luck.

 

I specified my Silent Post URL in my account configuration, but when I submit a transaction, the Silent Post URL is never getting requested.  I've looked in my Apache log files and there is no request from any client to the URL that I've specified in my account configuration.

 

Is there some place that I can check what error (if any) the Silent Post feature is reporting?

Highlighted
Member
Posts: 2
Registered: ‎04-25-2013

Re: Silent Post URL Not Working

And, just to add a little more information:

 

If I use a non-SSL URL, like:

 

http://www.mydomain.com/

 

That works, but if I use an SSL URL, like:

 

https://www.mydomain.com/

 

it seems not to work, despite the fact that I have a valid CA-signed SSL certificate.  I'm pretty sure that SSL negotiation is failing, perhaps due to the fact that I am using SNI-based SSL.  Does the Authorize.Net Silent Post URL work with SNI-based servers?

Highlighted
Posts: 1,609
Topics: 15
Kudos: 201
Solutions: 121
Registered: ‎06-23-2011

Re: Silent Post URL Not Working

It's possible that's the problem. Every site I've done so far has had a static IP with only one cert for that IP. How hard would it be for you to get an IP?

Highlighted
Contributor
Posts: 13
Registered: ‎06-05-2013

Re: Silent Post URL Not Working

Wondering if you got any resolution to this? I'm in the same boat.

 

Silent Post worked fine during development on http, the instant we went live on SNI - SSL (https), none of the Silent POST(s) from AUTH.net even show up in my server logs. Its got to be failing to the "ssl handshake".

 

Probably should just sent an email to get 100% clarification. Its not exactly easy these days to get another IPv4 address, so I'd rather not go that route.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Silent Post URL Not Working

Silent Post is very similar to relay response. And it will give you a response right away.

Read

Relay Response Basics and Troubleshooting

 

Highlighted
Contributor
Posts: 13
Registered: ‎06-05-2013

Re: Silent Post URL Not Working

Thanks for the response, but I already went through that checklist.

 

1) I copied and pasted the URL from control panel, directly into my browser to verify I typed it correctly. It loaded.

2) Even if it hit the "wrong" URL, I would still see it my access_logs.

3) We run https on port 443, which authorize.net supports.

4) The SSL is valid as all top 3 googles "ssl validation checker" reported.

5) The "test.authorize.net" which has been said a few times around these forums is quite slower / unsteady compared to the real envirnonment. If my scripts handle the test site without errors, then that elimates the variable of my scripts.

 

Unfortunately, this falls down to the SNI - SSL problem. Currently trying to get approved for another IPv4 address, along with sending an email to auth.net support.

 

I'll update this post when any details for future googlers.

 

If AUTH.net reads this. Why not add the same logging you have for relay_response for silent post? A simple "x failed with error when trying to POST"

Highlighted
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: Silent Post URL Not Working

 

Hi,
 
I can confirm that your guesses are correct and that, unfortunately, we do not support SNI based SSL authentication at this time.
 
Thanks,
Joy
Highlighted
Contributor
Posts: 13
Registered: ‎06-05-2013

Re: Silent Post URL Not Working

Any update on this? Just had to do another hacky fix for a new SNI Based SSL cert, and stuff like that isn't good.

Highlighted
Member
Posts: 3
Registered: ‎12-11-2013

Re: Silent Post URL Not Working

If this is a known bug, are you faimilar with any work around this issue?

 

Thanks.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: Silent Post URL Not Working

As mentioned earlier by Joy, you cannot currently use SNI certificates are not currently supported.

 

I'd recommend subscribing to this topic so that you'll be alerted via email if anyone else from the community. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies to your post.

Thanks,

Richard