Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 2
Registered: ‎03-22-2013

Stop the relay response from using HTTPS

I'm using this tag

 

<INPUT TYPE=HIDDEN NAME="x_relay_url" Value="<%= Url.Action("SimResponse", "Credit", new object { }, "Http")%>">

 

to pass my relay url as I've been instructed is the right way to handle this. So far every thing seems to work as expected. But when the url is called by authorize.net to send my user back to my site it uses Https on that url. Is there a variable some where that will allow me to tell authorize.net to quit doing that or is there a setting some where for that. I just want it to send the user to Http://mysite.com not Https://mysite.com.

 

Sorry for the overly simplified explanation this is about the sixth time I've explained my issue to some one(Not on this forum) so I guess I'm getting annoyed.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Stop the relay response from using HTTPS

Add the id attribute for x_relay_url.

Member
Posts: 2
Registered: ‎03-22-2013

Re: Stop the relay response from using HTTPS

Sorry this didn't work. (The name attribute is actually the important guy when your going from page to page any how) Thanks for the attempt.

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Stop the relay response from using HTTPS

[ Edited ]

Can you look at the page source when you run the page to see what the x_relay_url value is at run time?

 

p.s. authorize.net use the id attribute, try taking the id attribute for the x_login.