Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Highlighted
Member
Posts: 2
Registered: ‎04-14-2016

Support for php 5.3

Does anyone have any working sample code for asp or php 5.3

I'm on a windows system and have php 5.3. Seriallizer doesnt support 5.3 due to $().

Posts: 2,765
Topics: 57
Kudos: 270
Blog Posts: 67
Registered: ‎12-05-2011

Re: Support for php 5.3

Hello

I've reported your issue to the product team for analysis.  And I would also encourage you to open an issue on GitHub as well so you'll get immediate notification for updates.

Thanks,

Richard

Administrator
Posts: 149
Registered: ‎03-28-2014

Re: Support for php 5.3

I've removed any 5.3+ dependencies in the sample code and also made sure we include 5.3 in the Travis CI build and tests.  Everything green now for 5.3.

 

https://travis-ci.org/AuthorizeNet/sample-code-php

 

 

Let me know if there are any issues,

 

Brian

Member
Posts: 4
Registered: ‎05-10-2017

Re: Support for php 5.3

I cloned the sample code repo.

I updated composer.json and set the authorizenet version to 1.8.3.3 since that is the latest version that supports php 5.3.

 

composer ran successfully.

 

When I run

php CustomerProfiles/create-customer-profile.php

 

I get

php CustomerProfiles/create-customer-profile.php 


Fatal error: Class 'Goetas\Xsd\XsdToPhp\Jms\Handler\BaseTypesHandler' not found in /Users/bill.clark/Sites/AuthorizeNetSampleCode/vendor/authorizenet/authorizenet/lib/net/authorize/api/controller/base/ApiOperationBase.php on line 79

Call Stack:
    0.4076     680904   1. {main}() /Users/bill.clark/Sites/AuthorizeNetSampleCode/CustomerProfiles/create-customer-profile.php:0
    0.4128    1074696   2. createCustomerProfile() /Users/bill.clark/Sites/AuthorizeNetSampleCode/CustomerProfiles/create-customer-profile.php:74
    0.4187    1375288   3. net\authorize\api\controller\CreateCustomerProfileController->__construct() /Users/bill.clark/Sites/AuthorizeNetSampleCode/CustomerProfiles/create-customer-profile.php:57
    0.4187    1375416   4. net\authorize\api\controller\base\ApiOperationBase->__construct() /Users/bill.clark/Sites/AuthorizeNetSampleCode/vendor/authorizenet/authorizenet/lib/net/authorize/api/controller/CreateCustomerProfileController.php:12
    0.4242    1904352   5. JMS\Serializer\SerializerBuilder->configureHandlers() /Users/bill.clark/Sites/AuthorizeNetSampleCode/vendor/authorizenet/authorizenet/lib/net/authorize/api/controller/base/ApiOperationBase.php:82
    0.4242    1904400   6. net\authorize\api\controller\base\{closure}() /Users/bill.clark/Sites/AuthorizeNetSampleCode/vendor/jms/serializer/src/JMS/Serializer/SerializerBuilder.php:132

 

which is the same result I get from my current integration attempts with our codebase, which is stuck on php 5.3.

 

Any suggestions are appreciated.

Member
Posts: 4
Registered: ‎05-10-2017

Re: Support for php 5.3

[ Edited ]

No responses. nice.

 

For anyone stuck like me, try this: https://github.com/cystbear/AuthorizeNet-PHP-SDK

It is an authorizeNet library that has been tweaked to work with php 5.3

 

It is working for me.