Integration and Testing

Authorize.Net API questions and help with your payment integration.

Reply
Member
Posts: 3
Registered: ‎02-26-2014

Trouble connecting with Authorize.net from osCommerce (using AIM)

I'm trying to set up Authorize.net (AIM) within my new OSCommerce site. It keeps returning the error 'There has been an error processing your credit card. Please try again and if problems persist, please try another payment method.'

 

Please help.

 

Tech support that I need someone to help me find the response string so that they could further troubleshoot. I have no idea how to do this. 

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Trouble connecting with Authorize.net from osCommerce (using AIM)

You can login to your authorize.net merchant account, and find the settled or unsettled transaction and see what the response are. If there isn't any, it probably your osCommerce authorize.net settings is wrong.

Member
Posts: 3
Registered: ‎02-26-2014

Re: Trouble connecting with Authorize.net from osCommerce (using AIM)

I was able to log in and check and there were no transactions showing. What osCommerce settings for authorize.net do I need to troubleshoot? I just doublechecked the API login ID and I reset the transaction key and MD5 hash.

 

What else should I look for?

Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Trouble connecting with Authorize.net from osCommerce (using AIM)

Since it probably a settings issue on osCommerce, have you try their help?

Member
Posts: 3
Registered: ‎02-26-2014

Re: Trouble connecting with Authorize.net from osCommerce (using AIM)

I've reached out but haven't received a response yet.