Reply
Highlighted
Member
Posts: 3
Registered: ‎11-05-2012

Trying to create a customer profile with CIM on a test account...

Hi, I am using activemerchant with rails and am trying to integrate testing with CIM.

 

I was trying to test creating a profile transaction with CIM, however when I try to make the purchase in test mode, I get an error that I am in test mode and I cannot make a transaction...  So, I went to the developer site and made a test account, and now with that test account, I can't even make a profile...

 

I get the error:  "User authentication failed due to invalid authentication values."

 

...

 

Again, I can successfully create customer profiles and payment profiles with the "real" account, but for whatever reason I can't do it with the test account.

 

-patrick

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Trying to create a customer profile with CIM on a test account...

if you are using a test account, make sure activemerchant is using the test server. https://test.authorize.net

Highlighted
Member
Posts: 3
Registered: ‎11-05-2012

Re: Trying to create a customer profile with CIM on a test account...

activemerchant shows it is using this:

 

"https://apitest.authorize.net/xml/v1/request.api"

 

The error I get when trying to create a customer profile is E00007 "User authentication failed due to invalid authentication values."

 

Just to make sure, I created a new transaction ID, and carefully copy/pasted my api key & new transaction id...  Both are absolutely correct, so why it is failing authentication makes no sense to me.

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Trying to create a customer profile with CIM on a test account...

Try to generate a new transaction Key.

Highlighted
Member
Posts: 3
Registered: ‎11-05-2012

Re: Trying to create a customer profile with CIM on a test account...

perhaps you missed the part in my last reply that said: "Just to make sure, I created a new transaction ID, and carefully copy/pasted my api key & new transaction id...  Both are absolutely correct, so why it is failing authentication makes no sense to me."

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Trying to create a customer profile with CIM on a test account...

Don't know what else to tell you, I just try a new one and it works on the test server. Can you debug the code to make sure everything is correct at the time it make the call to authorize.net?