Reply
Highlighted
Contributor
Posts: 15
Registered: ‎06-12-2014
Accepted Solution

Unknown Error

I am current testing integration in live environment using SIM approach, and upon my first transaction the payment form displays Unknown Error. Anyone know what causes this to appear? 

 

I do not know how to upload images to this post, else I could provive a screenshot.


Accepted Solutions
Highlighted
Solution
Accepted by topic author Misfiring89
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

so you are running in testmode on a live account?

use 4111111111111111

View solution in original post

Highlighted
Solution
Accepted by topic author Misfiring89
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

Go in the merchant account and set something for the MD5, I wonder if there is a default that is set on the production account.

View solution in original post


All Replies
Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

What were the exact message? So the test account works on the test server, but now the live account doesn't work on the production server?

Highlighted
Contributor
Posts: 15
Registered: ‎06-12-2014

Re: Unknown Error

That's exactly it. The exact message is Unknown Error. That's it. I have no idea what this signifies.

 

 

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

Did you get it when it try to get to the payment form? or when you try to submit on the payment form?

Highlighted
Contributor
Posts: 15
Registered: ‎06-12-2014

Re: Unknown Error

After submit.

 

I use the usual credit card number that is used for testing. All other parameters should be correct since its able to display the payment form. The account is currently in Test Mode.

Highlighted
Solution
Accepted by topic author Misfiring89
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

so you are running in testmode on a live account?

use 4111111111111111

Highlighted
Contributor
Posts: 15
Registered: ‎06-12-2014

Re: Unknown Error

It worked. I can't believe that is what causing the problem. I say the documentation need a serious update as I can't find this 4111111111111111 anywhere. The redirect is successful so you have my thanks.

 

Now I have another issue though, the returned error message is "Unable to verify MD5 value.". I did not set any MD5 hash key in the merchant setting and I set the login key as the hash key in the relay url, which works in test site. 

Highlighted
Solution
Accepted by topic author Misfiring89
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Unknown Error

Go in the merchant account and set something for the MD5, I wonder if there is a default that is set on the production account.

Highlighted
Contributor
Posts: 15
Registered: ‎06-12-2014

Re: Unknown Error

Thanks for the help. Now things are going well, although it still tries to load my home page for a second before the relay page redirects to my receipt page. Other than that, it is working fine.