Reply
Member
Posts: 6
Registered: ‎05-04-2019

Upgrading AIM NVP

I was reading the AIM Upgrade Guide here (https://developer.authorize.net/api/upgrade_guide/), and it seems that we're still using the AIM NVP method because I still see field names starting with "x_" (x_login, x_tran_key, etc.).

What's said in the guide is that "These types of transaction requests can be brought current by recreating them using the methods described in Payment Transactions in the the API Reference using XML or JSON", but in the API Reference, I only see the XML tags and the PHP Code.

Are we supposed to upgrade our code by replacing the "x_" fields (x_login, x_tran_key, etc.) with the ones in PHP ($merchantAuthentication->setName, $merchantAuthentication->transactionKey, etc.)? If not, may we know how we can upgrade our AIM NVP Implementations?

Thanks :)

All Star
Posts: 683
Registered: ‎11-05-2018

Re: Upgrading AIM NVP

@zangief2000

You will need to download and install the PHP sdk. Then you will replace your current payment script with something new. You are using an SAQ D scope integration, so for you a good place to start would be the chargeCreditCard script in the sample code from the API reference.
Member
Posts: 6
Registered: ‎05-04-2019

Re: Upgrading AIM NVP


@Renaissance wrote:
@zangief2000

You will need to download and install the PHP sdk. Then you will replace your current payment script with something new. You are using an SAQ D scope integration, so for you a good place to start would be the chargeCreditCard script in the sample code from the API reference.

Awesome! Thanks for the tip @Renaissance . I'll try that out and hopefully that solves our problem.

 

Thanks again :)

Member
Posts: 6
Registered: ‎05-04-2019

Re: Upgrading AIM NVP


@Renaissance wrote:
@zangief2000

You will need to download and install the PHP sdk. Then you will replace your current payment script with something new. You are using an SAQ D scope integration, so for you a good place to start would be the chargeCreditCard script in the sample code from the API reference.

I'm sorry, but apparently we're not using AIM NVP, but AIM ARB. When looking at the Upgrade Guide it only indicated the solution for AIM NVP, so I automatically assumed it was that, but looking deeper, we're apparently using AIM ARB.

 

Since AIM ARB wasn't included in the list of EoL and deprecated methods, is it still recommended to upgrade AIM ARB to Authorize.Net API? If so, how would we be able to upgrade it?

Thanks :)

All Star
Posts: 683
Registered: ‎11-05-2018

Re: Upgrading AIM NVP

@zangief2000 

 

All AIM products are deprecated. You would integrate the ARB through the SDK as well.