Reply
Highlighted
Contributor
Posts: 18
Registered: ‎08-11-2017

Webhook transaction ID not found in transaction search

I have set up the webhook notification found Here that responds a api response of (example):

 

{
	"notificationId": "d0e8e7fe-c3e7-4add-a480-27bc5ce28a18",
	"eventType": "net.authorize.payment.authcapture.created",
	"eventDate": "2017-03-29T20:48:02.0080095Z",
	"webhookId": "63d6fea2-aa13-4b1d-a204-f5fbc15942b7",
	"payload": {
		"responseCode": 1,
		"authCode": "LZ6I19",
		"avsResponse": "Y",
		"authAmount": 45.00,
		"entityName": "transaction",
		"id": "60020981676"
	}
}

 

But it seems that no matter how many of these authcaptured notifications I get, none of the transaction ID are found when I try and query the api with

transactionDetailsController.getresponse()

I saw it may be due to latency, but even if I check transactions from a few days ago, in the admin panel or via API it does not say the transaction exists.

 

Every API response I have gotten starts with "614xxxxxxx" but if I log in to accounts.authorize.net and check my transactions they all start with "410xxxxxx"

 

I am unsure of how to get the IPN to notify me of a transaction and then be able to query via the API for information, since all the transactions the IPN is sending me apparently don't exist, even though they end up settled?

 

 

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: Webhook transaction ID not found in transaction search

[ Edited ]

@nadermx

 

That is very odd.  Please contact support at 877.447.3938 and have them check as well.  They have additional tools to further diagnose issues.

 

One other consideration to check.  When I run a sandbox transaction, the transaction id starts with 6011xxx.  You might confirm you're not sending transactions to the sandbox and then looking for webhooks in production.  Our two systems are completely separate.

 

Richard