Reply
Highlighted
Member
Posts: 2
Registered: ‎04-26-2017

Webhooks for ARB transactions is not working

We are in process to switch from silent-post to webhooks for one of our clients. I activated the following webhooks notifications on my sandbox account: 

  • "net.authorize.payment.authorization.created",
  • "net.authorize.payment.authcapture.created",
  • "net.authorize.payment.capture.created",
  • "net.authorize.payment.refund.created",
  • "net.authorize.payment.priorAuthCapture.created",
  • "net.authorize.payment.void.created",
  • "net.authorize.customer.created",
  • "net.authorize.customer.paymentProfile.created",
  • "net.authorize.customer.subscription.expiring",
  • "net.authorize.customer.subscription.updated"

I was able to receive notification from webhooks when I submitted a one-time test transaction. Yesterday we submitted a subscription (recurring) and today early morning after you ran the batch, I can see that subscription in my unsettled transactions and received the email for a successful transaction but nothing has been pushed to webhooks. 

Does webhooks supports sending notifications related to subscriptions? If it does why we are able to receive notification for one-time payments and not for recurring payments.

 

following section shows our enabled notifications: 

"webhookId": "af662353-7664-4d6f-9449-5a0e7995b4ee",
"status": "active",
"url": "http://.../webhooks.php",
"eventTypes": [
"net.authorize.payment.void.created",
"net.authorize.payment.capture.created",
"net.authorize.payment.authorization.created",
"net.authorize.payment.refund.created",
"net.authorize.customer.paymentProfile.created",
"net.authorize.customer.created",
"net.authorize.payment.priorAuthCapture.created",
"net.authorize.payment.authcapture.created",
"net.authorize.customer.subscription.expiring",
"net.authorize.customer.subscription.updated"
]

 

Thank you

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: Webhooks for ARB transactions is not working

Hello @amirsa

 

Are you still experiencing this issue?

 

Richard