Reply
Highlighted
Member
Posts: 4
Registered: ‎05-10-2015

Whitepage after changing transaction key, AIM

I changed the transaction key to the website. Site is designed with the AIM (php 5.3 and cURL). cURL library, simpleXML, php, etc are all enabled. The website has been working fine for months. No problems with checkout. 

 

However, after doing a routine change of the key, I am not able to complete the transaction...website goes to whitepage upon submit transaction...similar to a fatal php error. I rolled back the snippet code to the previous working version and reapplied the same key. Still whitepage. I applied new keys a few times more to try and make it work. It has been about 15 hours since the last key change. Still whitepage.

 

Note: transaction is not submitted. Card not charged. No record of transaction on Authorize.net transaction page.

Has any experienced this? Is there any reason Authorize.net would reject new transaction keys?

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Whitepage after changing transaction key, AIM

Can you tell what the response code and the response reason code is?

 

this is a test, change it with your loginID and transactionKey, run it in a browser and see what error it is.

https://secure.authorize.net/gateway/transact.dll?x_version=3.1&x_type=AUTH_ONLY&x_amount=12.00&x_de...

 

 

Highlighted
Member
Posts: 4
Registered: ‎05-10-2015

Re: Blank page after changing transaction key, AIM

@RaynorC1emen7Thank you for your post. The test URL gives the following response:

 

3,1,12,(TESTMODE) An authorization code is required but not present.,000000,P,0,,,12.00,,auth_only,,,,,,,,,,,,,,,,,,,,,,,,,,8399CF9006AB085A605D856FFDE35E8E,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

 

I then used my real CC information and was able to authorize & charge the card & get an email receipt. SUCCESS. It appears there is something wrong with the website php code sending the transaction url. I will roll back all related website pages to the previous working state and continue to examine the code. The transaction code is based on the php AIM sample code:

 

http://developer.authorize.net/resources/files/samplecode/php_aim.zip

 

---------------------------------------------

I should note the following at checkout submission: browser code =  200 = action completed successfully. Normally a blank page throws a 500 which is a PHP error but in this case there is nothing being logged since its a 200. No logging in CMS, MySQL, or Authorize.net transaction account.

Highlighted
Member
Posts: 4
Registered: ‎05-10-2015

Re: Blank page on old server too

The website is still active and loaded on the old server, which also has a dedicated IP, SSL, and the old x_tran_key. I changed my local hosts file and accessed my old website that had the old key. The website behaved normally, the checkout screen stated there was a problem (bc of the old key). I then updated the website with the new key and now I have the same problem not matter what = blank screen.

 

I changed back to the old key (on the old server), but still blank screen. I was very careful! There is no way I messed this up.

 

It seems that changing the keys caused Authorize.net to change it's response in such a way that causes my site to freeze, or the site is continuously waiting for a response from Authorize.net that never arrives.

 

Why would the website (on different servers) work fine before the key change...but then hang on a blank screen after the key change, when the only change was the new key?

 

I verified that the new key and login work fine. I even created a new .html page with included php & cURL and it worked fine. I am totally perplexed. If I had done nothing the site would be working fine. Any suggestions?

Highlighted
Member
Posts: 4
Registered: ‎05-10-2015

AuthorizeNet customer support?

Note: Customer support stated they are not able to help with anything other than giving me the meaning of response codes. I kindly told the rep I had the developer manual and URL to the code response tool. The service rep then asked me if I would like to cancel my Authorize.net account. Hmmm....I have been using Authorize.net for six (6) years on my ecommerce sites and virtual terminals....let's just say I've been a good customer. Does Authorize.net have support techs for escalations?

Highlighted
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: Blank page on old server too

I verified that the new key and login work fine. I even created a new .html page with included php & cURL and it worked fine. I am totally perplexed. If I had done nothing the site would be working fine. Any suggestions?

 

Can you cURL the test link the one the was in the previous post?

Can you log what your site cURL is sending to and what just before it does it and right after, log the time too.

 

 

 

Not sure about customer support, but they don't support development issue.