Reply
Highlighted
Member
Posts: 4
Registered: ‎04-10-2013

codingerror on Moodle Transaction

I've downloaded the latest plugin and installed in a Moodle 2.4.3 system.  I'm getting the following when the user submits a transaction.

 

Debug info:
Error code: codingerror

Stack trace:

  • line 1092 of /lib/dml/mysqli_native_moodle_database.php: coding_exception thrown
  • line 1149 of /lib/dml/mysqli_native_moodle_database.php: call to mysqli_native_moodle_database->insert_record_raw()
  • line 281 of /enrol/authorize/lib.php: call to mysqli_native_moodle_database->insert_record()
  • line 63 of /enrol/index.php: call to enrol_authorize_plugin->enrol_page_hook()

Output buffer: <div class="mdl-align"><p>This course requires a payment for entry.</p><p><b>Authorize.Net Payment Gateway</b></p><p><b>Cost: USD 2</b></p></div>

 

Any direction would be greatly appreciated.

Highlighted
Member
Posts: 4
Registered: ‎04-10-2013

Re: codingerror on Moodle Transaction

I tried uninstalling and reinstalling Authroize.net but that didn't change anything.  Still not able to use the plug-in.  Does anyone have the same problem or know why this might be happening?

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: codingerror on Moodle Transaction

Hello velocedge,

 

Which plugin for moodle are you using?  Have you also looked in the Moodle forums?

 

Richard

Highlighted
Member
Posts: 4
Registered: ‎04-10-2013

Re: codingerror on Moodle Transaction

version.php says 2012051300;

I downloaded it from: https://github.com/logicexpertise/moodle-enrol_authorize

 

I have not posted on Moodle yet.  I thought you would be the better source of information since I don't know if authorize.net is officially supported by Moodle 2.4.3.

Highlighted
Member
Posts: 4
Registered: ‎04-10-2013

Re: codingerror on Moodle Transaction

Should I be able to run Authorize.net with Moodle 2.4.3?... is anyone else running it on that Moodle version?

Highlighted
Member
Posts: 1
Registered: ‎09-25-2013

Re: codingerror on Moodle Transaction


@velocedge wrote:

Should I be able to run Authorize.net with Moodle 2.4.3?... is anyone else running it on that Moodle version?


Hi.  I realize this thread is a little old but I've just installed the same version as mentioned above and am using it just fine with Moodle 2.5.2.  I did make two changes.

 

First, there's a typo in the code at Github:

 

In enrol_form.php, line 168 is currently:

 

                $mform->setType('ccountry', PARAM_ALPHA);
 
and should be:
 
                $mform->setType('cccountry', PARAM_ALPHA);
 
(There should be 3 letter c's in a row)  Otherwise it throws a "type not set" warning when writing into the database.
 
I also downloaded the current Authorize.net SDK and used that instead of the one supplied at Github. 
 
Terry