Reply
Member
Posts: 1
Registered: ‎08-30-2018

createTransactionResponse Still Processing Card While Returning Error Condition

I have recently switched from CIM to Accept Hosted and I’m having a strange issue.  I am trying to test our payment processing in production.  Some payments are processing fine but I’m having issues with a company Amex card and a persona Visa card.  I am using the createTransactionRequest here is the results that I’m seeing (this one is from the Amex card):

 

<createTransactionResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

    <refId>5B88C98E52C66NJB</refId>

    <messages>

        <resultCode>Ok</resultCode>

        <message>

            <code>I00001</code>

            <text>Successful.</text>

        </message>

    </messages>

    <transactionResponse>

        <responseCode>2</responseCode>

        <authCode>255903</authCode>

        <avsResultCode>B</avsResultCode>

        <cvvResultCode>M</cvvResultCode>

        <cavvResultCode/>

        <transId>40908629799</transId>

        <refTransID>40908629799</refTransID>

        <transHash>6552ED2EA4E89917B67551FB64CAD856</transHash>

        <testRequest>0</testRequest>

        <accountNumber>XXXX1050</accountNumber>

        <accountType>AmericanExpress</accountType>

        <errors>

            <error>

                <errorCode>27</errorCode>

                <errorText>The transaction has been declined because of an AVS mismatch. The address provided does not match billing address of cardholder.</errorText>

            </error>

        </errors>

        <transHashSha2/>

    </transactionResponse>

</createTransactionResponse>

 

So resultCode is “OK (as expected) and responseCode is returning with a “2” with errorCode of “27” saying we we failed AVS match (not sure why but that is a different issue).

 

I logged into our Auth Merchant account and these charge attempts are all shown as “declined” as I would expect give the 2/27 error codes returned.

The kicker is that the charges actually hit the cards. 

 

It’s my understanding from reading the documentation that I need resultCode to be “OK” AND responseCode to be “1” for a transaction to be good.  Are there exceptions when resultCode is "OK" and responseCode is 2? 

 

Administrator
Posts: 170
Registered: ‎11-29-2017

Re: createTransactionResponse Still Processing Card While Returning Error Condition

There are two things going on with this response. First, the card issuer (American Express, for example) did authorize the transaction (see authCode field), but when the response was returned to Authorize.Net, it was declined based on the account's Fraud Detection Suite Address Verification Settings.

 

Check the address information provided with the transaction to see why the card issuer would send back this response.

 

avsResultCode 'B' -

Address information was not submitted in the transaction information, so AVS check could not be performed

 

The authorization is a temporary hold on the funds and as it was declined at Authorize.Net the hold will be released by the card issuer and the transaction will not be funded.