Reply
Member
Posts: 4
Registered: ‎04-10-2017

error E00114 - Invalid OTS Token Errors

Hi

 

This is my first attempt to implement the Accept.js API. The application I'm integrating into as a .NET web application.

 

Using the sample provided I am consistently able to pass card data the the Authorize.net service and get back a success response and a nonce.

 

To process the actual tranaction I've taken the CreateAnAcceptTransaction.cs from the sample code provided on github. If I plug in my credentials and the nonce returned above I get a null response 100% of the time with the error being error E00114 - Invalid OTS Token. I assume I must have something configured incorrectly somewhere but I'm struggling mightily to figure outwhere that is.

 

Any advice or direction about how to troubleshoot this error is much appreciated. As it is I'm dead in the water.

 

Regards and thank you.

 

--Vinny Myles

Posts: 2,319
Topics: 51
Kudos: 157
Blog Posts: 65
Registered: ‎12-05-2011

Re: error E00114 - Invalid OTS Token Errors

Hello @vmyles

 

If you are testing in the sandbox, make certain you are obtaining your nonce by calling the test environment:

 

<!-- For Sandbox/Testing, use: -->
    <script type="text/javascript" src="https://jstest.authorize.net/v1/Accept.js" charset="utf-8"></script>
<!-- For Production, use: -->
    <script type="text/javascript" src="https://js.authorize.net/v1/Accept.js" charset="utf-8"></script>

And then when using the nonce you are using the sandbox endpoint as well.

 

Richard

--------

Webhooks are now available for Authorize.Net

Using SOAP, see our deprecation notice.
Check out Accept.js, our Javascript replacement for DPM.
Pro Tip: Never use test mode in the sandbox, instead use the Testing Guide.
Member
Posts: 4
Registered: ‎04-10-2017

Re: error E00114 - Invalid OTS Token Errors

Hi Richard

 

Thanks very much for getting back to me. I am in fact pointed at the sandbox in both places in my code.

 

I did manage to find the "try it" page. Attempting an Accept transaction there failed with the same error. That would seem to point to some issue with the test account or account settings? I went through the settings and could not find it. Apologies if I'm missing something obvious.

 

Regards

 

--Vinny Myles

Highlighted
Member
Posts: 4
Registered: ‎04-10-2017

Re: error E00114 - Invalid OTS Token Errors

For the record this turned out to be an error in my adaptation of the sample code. A couple of rounds with a very helpful person in support led me to it. I seem to be in business.

 

Thanks for your help.

 

--Vinny Myles

New Member
Posts: 1
Registered: ‎07-14-2017

Re: error E00114 - Invalid OTS Token Errors

[ Edited ]

Hi Vinny,

 

What mistake did you make because, without changing anything in my code, it changed from working to not working overnight.

 

If anything could give me a hint in the right direction it would be awesome.

 

Thanks,

 

D.

Member
Posts: 4
Registered: ‎04-10-2017

Re: error E00114 - Invalid OTS Token Errors

There was one spot in the sample I adapted where I left in the default token instead of replacing it with mine. It was entirely my fault, nothing on the Authorize.net end.

 

--Vinny