Reply
Member
Posts: 2
Registered: ‎04-24-2018
Accepted Solution

hostedPaymentIFrameCommunicatorUrl not referenced in payment form

[ Edited ]

What am I doing wrong?

 

  • I’m making a JSON request for the payment form
  • The form is returned, but does not reference the hostedPaymentIFrameCommunicatorUrl parameter.
     
    JSON request below.
    As far as I can tell, the format matches the example on the Authorize.Net Accept Hosted page
     
    {
      "getHostedPaymentPageRequest": {
        "merchantAuthentication": {
          "name": "26qQeN7z",
          "transactionKey": "aaaaaaaaaaaaaaaa"
        },
        "transactionRequest": {
          "transactionType": "authCaptureTransaction",
          "amount": 5
        },
        "hostedPaymentSettings": {
          "setting": [
            {
              "settingName": "hostedPaymentIFrameCommunicatorUrl",
              "settingValue": "{\"url\":\"https://test.yourweddingcompany.com/ywc_communicator.php\"}"
            },
            {
              "settingName": "hostedPaymentPaymentOptions",
              "settingValue": "{\"cardCodeRequired\":true}"
            },
            {
              "settingName": "hostedPaymentShippingAddressOptions",
              "settingValue": "{\"show\":true,\"required\":true}"
            },
            {
              "settingName": "hostedPaymentBillingAddressOptions",
              "settingValue": "{\"show\":true,\"required\":true}"
            },
            {
              "settingName": "hostedPaymentCustomerOptions",
              "settingValue": "{\"showEmail\":true,\"requiredEmail\":true}"
            },
            {
              "settingName": "hostedPaymentOrderOptions",
              "settingValue": "{\"show\":true,\"merchantName\":\"Your Wedding Company\"}"
            }
          ]
        }
      }
    }

    Here is the resulting DOM.

    Note that it has loaded the payment form, but the form does not reference hostedPaymentIFrameCommunicatorUrl:

     

    DOM image

     

Accepted Solutions
Solution
Accepted by topic author pskovacs
‎04-26-2018 08:56 PM
Member
Posts: 2
Registered: ‎04-24-2018

Re: hostedPaymentIFrameCommunicatorUrl not referenced in payment form

I solved the problem. Everything below is correct.

 

The intent had been to display the payment form once it communicated its size via the communicator page.

 

Setting display:none on the iframe's container somehow prevents the payment form from loading the communicator url.

 

Using visibility:hidden instead fixes the problem.

View solution in original post


All Replies
Solution
Accepted by topic author pskovacs
‎04-26-2018 08:56 PM
Member
Posts: 2
Registered: ‎04-24-2018

Re: hostedPaymentIFrameCommunicatorUrl not referenced in payment form

I solved the problem. Everything below is correct.

 

The intent had been to display the payment form once it communicated its size via the communicator page.

 

Setting display:none on the iframe's container somehow prevents the payment form from loading the communicator url.

 

Using visibility:hidden instead fixes the problem.