Reply
Member
Posts: 3
Registered: ‎08-20-2013

iOS 6.1 and Support for iOS 7

[ Edited ]

Hi this is a two part question. I'll start off with the easy one first.

 

1. Will the current Authorize.net iOS SDK support iOS 7? 

 

2. I'm having issues getting the current Authorize.net IOS SDK to build with my iOS 6.1 project. I've added a reference to the static lib in my project frameworks and I've made sure the linker flag -libxml2 and the search paths which point to the static lib in the SDK folder are in the project settings as well. I've also added the SystemConfiguration.framework to the project frameworks. According to the readme file this is all that needs to be done, but when I try to build the project I get the below error. According to the readme file this is all that needs to be done. Am I missing something? 

 

ld: warning: ignoring file /Users/cent204/Library/Developer/Xcode/DerivedData/ANMobilePaymentLib-gbhewvsajmbcjafiweprzfkcitcb/Build/Products/Debug-iphoneos/libANMobilePaymentLib.a, missing required architecture i386 in file /Users/cent204/Library/Developer/Xcode/DerivedData/ANMobilePaymentLib-gbhewvsajmbcjafiweprzfkcitcb/Build/Products/Debug-iphoneos/libANMobilePaymentLib.a (2 slices)

 

Any help would be appreciated as well as feedback on the compatiblity and support of iOS 7. 

 

Thank you.

Member
Posts: 3
Registered: ‎08-20-2013

Re: iOS 6.1 and Support for iOS 7

Nevermind to the iOS 6.1 issues. Realized the lib was not a universal library, works fine on the device. Ended up creating a universal library so that I can test on the simulators.