Reply
Highlighted
Member
Posts: 5
Registered: ‎09-25-2017

iOS Accept SDK Integration Issue

Trying to integrate the Swift Accept SDK, and I'm getting an error when i'm installing the iOS Accept SDK. It's telling me that it is using the 3.0 swift version and I'm using 3.2 (which is the latest release). Is there any timeline on when this will be updated?

 

Also concerned that the SDK isn't being regularly maintained, and was wondering if there is a roadmap for this or if it will be maintained going forward.

 

Thank you.

Highlighted
Member
Posts: 5
Registered: ‎09-25-2017

Re: iOS Accept SDK Integration Issue

Is there any update on this?

 

Trying to test new integration but this is making it difficult.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: iOS Accept SDK Integration Issue

Hello @kylehorn

 

I would recommend opening an issue on GitHub directly, the development team responsible will be notified directly.

 

Richard

Highlighted
Member
Posts: 5
Registered: ‎09-25-2017

Re: iOS Accept SDK Integration Issue

There are multiple issues opened already for this issue, along with many others that haven't been resolved. I called support who referred me to here. If you can escalate this issue that would be a huge appreciation.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: iOS Accept SDK Integration Issue

Hello @kylehorn

 

A new release on GitHub is now available that may solve your issue.  Please take a look and let us know.

 

Richard

Highlighted
Member
Posts: 5
Registered: ‎09-25-2017

Re: iOS Accept SDK Integration Issue

I see the release on Github now, but it still doesn't bring it up to date with the latest version of swift, so I still am experiencing the issue.


It would need to support at least 3.2 and possibly 4.

 

I'm concerned with how much of an issue this is, with adopting it for our project.

Highlighted
Posts: 2,765
Topics: 57
Kudos: 247
Blog Posts: 67
Registered: ‎12-05-2011

Re: iOS Accept SDK Integration Issue

@kylehorn

 

I've escalated this to our API product manager and hope to get a response soon.

 

Richard

Highlighted
Member
Posts: 5
Registered: ‎09-25-2017

Re: iOS Accept SDK Integration Issue

Thank you.

 

I"m also getting an error when I manually build the framework and include it, when I upload to the app store. There are multiple issues open on Github regarding this as well.

Highlighted
All Star
Posts: 699
Registered: ‎11-03-2016

Re: iOS Accept SDK Integration Issue

Hi @kylehorn

 

The SDK has been built against Swift 4.0 now. If you have any further problems, please raise them here or at GitHub and we'll see that they're fixed.

Highlighted
Contributor
Posts: 17
Registered: ‎05-29-2018

Re: iOS Accept SDK Integration Issue

This appears to be an issue again with the Accept SDK iOS.  Swift is now 4.1 and the Authorize.net build is still at 4.0.  Several developers have noted this on Github MONTHS ago.  I'm concerned that maintenance of the SDK is going to be an issue.