Reply
Member
Posts: 4
Registered: ‎05-22-2019

lower versions of IE(7,8,9) support for Authorize.Net HPP integration

We have implemented HPP integration for Credit Card with IFrameComunicator in our web application in .net 4.5.Also our web app supports TLS 1.2. HPP integration is working with IE 10,11,Chrome,Firefox and Safari as expected. As our web application is IE specific, we are facing issues with IE 7,8,9.

 

The issue we are facing on IE 7,8,9 is

1.Credit Card fields i.e. Credit Card number,Exp Date,Card Code,Pay and Cancel buttons are not getting loaded. In transactionsettings , we have setting to display only credit card details,Pay and Cancel button.

2. We analyzed by pressing F12 that some .js and .css files from Authorize.net API are not getting loaded e.g. style.bundle.css,inline.bundle.js

 

We have checked below link for Browser Recommendations for TLS/SSL support

https://support.authorize.net/s/article/Authorize-Net-Support-for-SSL-TLS-FAQ?#Browser

 

For IE, it is mentioned as below

Internet Explorer (IE) - Version 11 of IE is recommended at it is the latest and newest version of IE. It is also recommended to be on at least Windows 7.

  • Lower versions of IE (8, 9, 10) do not support TLS 1.2 by default as manual changes are needed in your browser and OS settings to enable and are not recommended.

Does lower versions of IE supports HPP integration or will it not support at all or what manual changes are needed in browser and OS settings to enable?

 

Thanks in advance.

 

Rohini Kajave

 

 

 

 

 

Posts: 2,765
Topics: 57
Kudos: 245
Blog Posts: 67
Registered: ‎12-05-2011

Re: lower versions of IE(7,8,9) support for Authorize.Net HPP integration

Hello @rohinikajave 

 

You might find this article helpful: https://knowledge.digicert.com/generalinformation/INFO3299.html#IE

 

Richard

Highlighted
Member
Posts: 4
Registered: ‎05-22-2019

Re: lower versions of IE(7,8,9) support for Authorize.Net HPP integration

Hello @RichardH 

 

Thank you!!!!