Reply
Posts: 2,765
Topics: 57
Kudos: 269
Blog Posts: 67
Registered: ‎12-05-2011

Re: no data in x_SHA2_Hash when using Silent Post

@MinneSnowtain At present, we're unable to duplicate the issue you are reporting so we need an example that we can test ourselves.

 

Richard

Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

[ Edited ]

<form action="https://test.authorize.net/gateway/transact.dll" method="post">
<input type="HIDDEN" name="x_fp_sequence" value="28897">
<input type="HIDDEN" name="x_fp_timestamp" value="1551197199">
<input type="HIDDEN" name="x_fp_hash" value="1F654DD87486F5F5314E9E03428762B7">
<input type="HIDDEN" name="x_login" value="3Ac2GnPa9X9b">
<input type="HIDDEN" name="x_show_form" value="PAYMENT_FORM">
<input type="HIDDEN" name="x_amount" value="80.00">
<input type="HIDDEN" name="x_method" value="CC">
<input type="HIDDEN" name="x_type" value="AUTH_CAPTURE">
<input type="HIDDEN" name="x_invoice_num" value="28897">
<input type="HIDDEN" name="x_description" value="this is a test">
<input type="HIDDEN" name="x_cust_id" value="12234">
<input type="HIDDEN" name="x_company" value="Testing">
<input type="HIDDEN" name="x_first_name" value="tfn">
<input type="HIDDEN" name="x_last_name" value="fln">
<input type="HIDDEN" name="x_address" value="123 test">
<input type="HIDDEN" name="x_city" value="somewhere">
<input type="HIDDEN" name="x_state" value="mn">
<input type="HIDDEN" name="x_zip" value="55744">
<input type="HIDDEN" name="x_phone" value="111-111-1111">
<input type="HIDDEN" name="x_email" value="test@testing.com">
<input type="HIDDEN" name="x_po_num" value="">
<input type="HIDDEN" name="x_duplicate_window" value="28800">
<input type="HIDDEN" name="x_country" value="US">
<input type="HIDDEN" name="x_currency_code" value="USD">

<input type="HIDDEN" name="x_header_html_payment_form" value="">
<input type="HIDDEN" name="x_footer_html_payment_form" value="If you have any difficulty or questions please call customer support at ">
<input type="HIDDEN" name="x_customer_ip" value="10.1.1.136">
<input type="HIDDEN" name="header_html" value="">
<input type="HIDDEN" name="return_url" value="">
<input type="hidden" name="x_test_request" value="TRUE">
<input type="SUBMIT" value="Click here to pay with a credit card securely on-line">
</form>

 

 

Click the submit button which brings up your payment gateway https://test.authorize.net/gateway/transact.dll I fill out the billing info useing the visa test cc from https://developer.authorize.net/hello_world/testing_guide/ click the pay now button and I get the posted data FROM YOU of 

X_MD5_HASH 4D242833C50615331720B3BECAC476D3

 

X_SHA2_HASH

[empty string]

 

Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

@RichardH  I've tried a couple times but my response keeps getting rejected as spam.

Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

@RichardH 

 

trying this another way

 

so we post data to you site, https://test.authorize.net/gateway/transact.dll.  user fills it out hits pay now button that then process and post back to our silent post url. the data YOU SEND BACK to us is missing a value in the X_SHA2_HASH field..it's empty and the data in the X_MD5_HASH field no longer matches.

Posts: 2,765
Topics: 57
Kudos: 269
Blog Posts: 67
Registered: ‎12-05-2011

Re: no data in x_SHA2_Hash when using Silent Post

I was able to move your post from the spam quarantine.

Highlighted
Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

@RichardH 

 

I see that, thank you!  Now if you can fix the sandbox silent post return I'll take back everything I've been muttering under my breath.

Posts: 2,765
Topics: 57
Kudos: 269
Blog Posts: 67
Registered: ‎12-05-2011

Re: no data in x_SHA2_Hash when using Silent Post

Hello @MinneSnowtain 

 

Checking your sandbox account, we noted your sandbox account has not generated a signature key.    Please do that and try again.

 

4A59D012.PNG

Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

@RichardH 

 

Okay and what do I do with that?

Posts: 2,765
Topics: 57
Kudos: 269
Blog Posts: 67
Registered: ‎12-05-2011

Re: no data in x_SHA2_Hash when using Silent Post

@MinneSnowtain 

 

The Signature Key is used to validate that transactions are authentic and from Authorize.Net.  If you're using the MD5 hash today for validation, you'll need to update your integration to use the SHA2 hash as outlined here: https://support.authorize.net/s/article/MD5-Hash-End-of-Life-Signature-Key-Replacement

 

Richard

 

 

Contributor
Posts: 24
Registered: ‎02-26-2019

Re: no data in x_SHA2_Hash when using Silent Post

@RichardH   

 

oooh I see if I have that key the X_SHA2_HASH is populated!  Could you please confirm the hashed string?  seen a number of conflicting reports as far as does it start with ^ I'm using this:

#x_login#^#form.x_fp_sequence#^#form.x_fp_timestamp#^#form.x_amount#^#form.x_currency_code#  could you please confirm that is the correct string?