Reply
Member
Posts: 3
Registered: ‎12-13-2017

no response code sent back when using Apple Pay

Hello,

 

I'm an iOS developer using the authorize api with a mobile app where customers use apple pay to add funds to their account. Most of the time when authorize.net processes the payment successfully it sends back a response code to the app telling the user that the payment was either successful or not successful. Every now and then however the app doesn't receive a response code eventhough the payment was processed successfully. I'm not sure if the app is being sent empty data or null data or even how authorize suggests mobile apps should handle those types of situations. If anyone could help me figure out why I don't receive a response code sometimes I would be extremely grateful. 

Authorize.Net Expert
Posts: 75
Registered: ‎07-27-2016

Re: no response code sent back when using Apple Pay

Hello @ramaez

 

Can you share more information on how exactly are you making the api calls to Authorize.Net.

Are you making call to our gateway directly from the app itself or from a app backend server ?

 

Also when you are saying you the app doesn't receive a response code eventhough the payment was processed successfully, do you receive any response from the gateway ?

 

Usually you should be getting an response like this if the transaction was processed successfully.

<messages>
    <resultCode>Ok</resultCode>
    <message>
      <code>I00001</code>
      <text>Successful.</text>
    </message>
  </messages>

 

 

Member
Posts: 3
Registered: ‎12-13-2017

Re: no response code sent back when using Apple Pay

The API call is made directly from the app itself. Normally when the payment process is successful we get a response code like:

 

<messages><resultCode>Ok</resultCode><message><code>I00001</code><text>Successful.</text></message></messages>

 

With response code 1

 

Since the process is done asynchronously there's a possibility that the connection is timing out though I'm not sure what the best practice for fixing that issue would be.

Authorize.Net Expert
Posts: 75
Registered: ‎07-27-2016

Re: no response code sent back when using Apple Pay

Hi @ramaez

 

The API call you are making from the app shuld be routed through your application backend server, as the network connectivety of the phone is not reliable.

 

Also if you are not getting back a response can you check if the transaction went through or not via the Sandbox Merchant interface. : https://sandbox.authorize.net/

 

also if you still prefer to make the transaction request from the app directly you can use webhooks to get notification for an trasaction to your server : https://developer.authorize.net/api/reference/features/webhooks.html