Reply
Member
Posts: 9
Registered: ‎10-27-2015
Accepted Solution

testing in live mode in production didn't raise errors like the sandbox did

[ Edited ]

I'm submitting the error code 46205 and ccv 900 to visa test card number and I get a successful transaction rather than an avs error.   The account has checked to reject mismatched address and zip, but it apparently did not.  I was able to raise the avs error codes in the sandbox.. How do I test avs and cvv verification in live mode?  Thanks

 

Response from Stream: '<?xml version="1.0" encoding="utf-8"?>
<createTransactionResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
<messages>
<resultCode>Ok</resultCode>
<message>
<code>I00001</code>
<text>Successful.</text>
</message>
</messages>
<transactionResponse>
<responseCode>1</responseCode>
<authCode>000000</authCode>
<avsResultCode>P</avsResultCode>
<cvvResultCode /><cavvResultCode />
<transId>0</transId><refTransID />
<transHash>C6546E99C4271955E0B34354453435</transHash>
<testRequest>1</testRequest>
<accountNumber>XXXX1111</accountNumber>
<accountType>Visa</accountType>
<messages>
<message>
<code>1</code>
<description>This transaction has been approved.</description>
</message>
</messages>
</transactionResponse>
</createTransactionResponse>


Accepted Solutions
Solution
Accepted by topic author twe
‎10-30-2015 05:22 PM
Posts: 2,765
Topics: 57
Kudos: 251
Blog Posts: 67
Registered: ‎12-05-2011

Re: testing in live mode in production didn't raise errors like the sandbox did

[ Edited ]

Using the testing guide to generate specific responses only works in the sandbox.  Also, using test mode only confirms if the credentials are correct and returns success, it does not attempt a transaction nor does it store anything.  You can see in your response that there was no transaction ID generated.

 

Richard

View solution in original post


All Replies
Solution
Accepted by topic author twe
‎10-30-2015 05:22 PM
Posts: 2,765
Topics: 57
Kudos: 251
Blog Posts: 67
Registered: ‎12-05-2011

Re: testing in live mode in production didn't raise errors like the sandbox did

[ Edited ]

Using the testing guide to generate specific responses only works in the sandbox.  Also, using test mode only confirms if the credentials are correct and returns success, it does not attempt a transaction nor does it store anything.  You can see in your response that there was no transaction ID generated.

 

Richard

Member
Posts: 9
Registered: ‎10-27-2015

Re: testing in live mode in production didn't raise errors like the sandbox did

thank you