Member
Posts: 2
Registered: ‎01-14-2014
SIM Integration Relay Response Script Timing Out Error

Hey Folks,

 

I've got a very tough issue here.

 

We're using the SIM Integration method, and we've got a relay response page.

 

We're processing several thousand transactions a day, and the vast majority of them ARE successful, so I'm fairly certain this is not a configuration issue.

 

HOWEVER, every so often we get a transaction that clears successfully on auth.net, but the order doesn't show up recorded in our system. Then we get the e-mail from auth.net saying "Your script timed out while we were trying to post transaction results to it. "

 

I can see the request to our relay response page in my access logs, so I know the request was made. Also, there is NO corresponding error in my error logs at that timestamp, so I know the page loaded.

 

For some reason, it seems that Auth.net's servers are having to wait more than 10 seconds (the timeout window according to the documentation) for our page to come back. There are no complex scripts on our relay response page, it's generated instantly. And, as I said above, this setup works the majority of the time.

 

So here's the question: how can I avoid this? Why is the timeout window so small? And if this happens, what's best-practice for recovering from it?

 

I wish I could talk to an actual engineer about it on the phone, but all I ever get are sales folks who direct me here to the message boards. :)

 

Thanks in advance for any advice...

Who Me Too'd this topic