Reply
Contributor
Posts: 20
Registered: ‎07-13-2011
Accepted Solution

AuthorizeNet DPM not working, but no errors:

[ Edited ]

For some reason the DPM that we tested and was working properly is no longer working.  Now we did recently change to the new post URL

 

This is the form post we are sending:
With the credit card PAN data obfusicated and the addresses changed.
The transaction doesn't even show up in our virtual terminal as unsettled or failed.
Your system gives us "no debug" information at all as to what the problem might be. The response code is 3 but since the transactions don't even show up as failed, it appears to be some kind of issue.

 

DPM Post

<input type='hidden' name='x_Invoice_Num' value='451' />
<input type='hidden' name='x_Amount' value='35.00' />
<input type='hidden' name='x_Relay_Url' value='https://www.salescart.net/checkout20/SPAuthRelay.aspx' />
<input type='hidden' name='x_Login' value='cccdc0506' />
<input type='hidden' name='x_Version' value=' value='3.1' />
<input type='hidden' name='x_solution_id' value=' value='A1000132' />
<input type='hidden' name='x_Method' value=' value='CC' />
<input type='hidden' name='x_Type' value='Auth_Capture' />
<input type='hidden' name='x_Test_Request' value='False' />
<input type='hidden' name='x_Description' value='Automatically Generated SalesCart Order' />
<input type='hidden' name='x_fp_timestamp' value='1446135605' />
<input type='hidden' name='x_fp_sequence' value='451' />
<input type='hidden' name='x_posturl' value='https://secure2.authorize.net/gateway/transact.dll' />
<input type='hidden' name='x_card_num' value='41111*' />
<input type='hidden' name='x_exp_date' value='7/19' />
<input type='hidden' name='x_card_code' value='123' />
<input type='hidden' name='x_Merchant_Email' value='no-one@com2city.com' />
<input type='hidden' name='x_recurring_billing' value='N' />
<input type='hidden' name='x_Cust_ID' value='17' />
<input type='hidden' name='x_fp_hash' value='****4149ddc68e862a030' />
<input type='hidden' name='x_Last_Name' value='Mr. Spence' />
<input type='hidden' name='x_First_Name' value='Wayne' />
<input type='hidden' name='x_Company' value='Tea Co.' />
<input type='hidden' name='x_Address' value='123 Jasmin Place' />
<input type='hidden' name='x_City' value='Seattle' />
<input type='hidden' name='x_State' value='WA' />
<input type='hidden' name='x_Zip' value='98027' />
<input type='hidden' name='x_Country' value='US' />
<input type='hidden' name='x_Phone' value='(425)-213-6512' />
<input type='hidden' name='x_Email' value='no-one@com2city.com' />
<input type='hidden' name='x_ship_to_last_name' value='Spence' />
<input type='hidden' name='x_ship_to_first_name' value='Wayne' />
<input type='hidden' name='x_ship_to_company' value='Tea Co.' />
<input type='hidden' name='x_ship_to_address' value='123 Jasmin Place' />
<input type='hidden' name='x_ship_to_city' value='Seattle' />
<input type='hidden' name='x_ship_to_state' value='WA' />
<input type='hidden' name='x_ship_to_zip' value='98027' />
<input type='hidden' name='x_ship_to_country' value='US' />
<input type='hidden' name='x_Freight' value='0' />
<input type='hidden' name='x_Tax' value='0.00' />

 

This is the result spit out:

AuthorizeNet DPM Debug and Test
Response Code: 3 
Reason: 265:This transaction cannot be processed. 
Trans. Code: 0 
Auth. Code: 
AVS Code: P: AVS not applicable for this transaction. 
Invoice: 451 
Amount: 35.00 
Error?: 
Is Valid? True
Msg= 

 


Accepted Solutions
Highlighted
Solution
Accepted by topic author spastic
‎11-05-2015 02:05 PM
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: AuthorizeNet DPM not working, but no errors:

 

Hi Mike,

 

The error 265 indicates that you are passing an invalid solution ID so I double checked and confirmed that this solution ID is correct and valid for A1000132. My best recommendation is to confirm what exactly is being passed here using a browser developer console.

 

Thanks,

Joy

View solution in original post


All Replies
Highlighted
Solution
Accepted by topic author spastic
‎11-05-2015 02:05 PM
Administrator Administrator
Administrator
Posts: 563
Registered: ‎08-03-2011

Re: AuthorizeNet DPM not working, but no errors:

 

Hi Mike,

 

The error 265 indicates that you are passing an invalid solution ID so I double checked and confirmed that this solution ID is correct and valid for A1000132. My best recommendation is to confirm what exactly is being passed here using a browser developer console.

 

Thanks,

Joy

Contributor
Posts: 20
Registered: ‎07-13-2011

Re: AuthorizeNet DPM not working, but no errors:

We got it working again.

It would be helpful that during a testing transaction, your system would save a log file for the last post and response as seen from your side that can be seen if you log into the virtual terminal.