Reply
Highlighted
Member
Posts: 3
Registered: ‎11-08-2017

Issue with hosted form - Entering all the details still form says Bill to first name is required.

I am using hosted form to make payments from our site. Everything was working well 3 days before but from last 3 days I am facing an issue that is, I am entering all the details correctly in hosted form but hosted form still says Bill to first name is required.

 


We have setting as required for hosted form fields in our Authrize dashboard in account->setting->form-fields (first-name, last-name, address and all) and if we remove the restriction of required card starts working.

 

 

I tested with two different cards.

 

Now the issue is when we make it required and we are entered all the details (firstname, lastname ,address)and then it still says bill to firstname is required.
is it related to something authrize system error or something else kindly confirm.

 

Any help is appriciated.

 

Regards

 

Rahul Thakral
Email: thakral.rahul1310@gmail.com
Phone: +91-9996845879

 

Payment with first card

 

Payment with second card

Highlighted
Member
Posts: 3
Registered: ‎11-08-2017

Re: Issue with hosted form - Entering all the details still form says Bill to first name is required

[ Edited ]

 

 

I have used the method of

Get an Accept Payment Page which which is availble here on authorize

 

https://developer.authorize.net/api/reference/index.html#payment-transactions-get-an-accept-payment-...

 

the function given for this method first generate the token for payment and then we have to post the token with required data to

https://accept.authorize.net/payment/payment

 

and over there I got this error - see screenshots:

 

http://prntscr.com/h7odo6

http://prntscr.com/h7odzc

 

with the above screenshots you can have idea that there is no transactions happening so no response that I can submit here for debugging.

 

One more things and this payment was working 3 days before but from last 3 days its not working.

 

Any solution is welcome. Authorize developer support put their hands up and replied that we provide limited support.

Highlighted
All Star
Posts: 699
Registered: ‎11-03-2016

Re: Issue with hosted form - Entering all the details still form says Bill to first name is required

Hi @thakralrahul38,

 

Can you duplicate this problem on our sandbox system, or only on the production system?

 

It would be very helpful if you could post a sample token request, or the code you use to generate the token request.

Highlighted
Member
Posts: 8
Registered: ‎04-30-2017

Re: Issue with hosted form - Entering all the details still form says Bill to first name is required

Has a solution been determined for this issue?

I'm experiencing the same exact problem, which started about the same time.

 

BertQ

Highlighted
Member
Posts: 8
Registered: ‎04-30-2017

Re: Issue with hosted form - Entering all the details still form says Bill to first name is required

I found a workaround that seems to fix the issue:

 

I added the following code to getHosted.php file:

 

    $setting4 = new AnetAPI\SettingType();

    $setting4->setSettingName("hostedPaymentBillingAddressOptions");

    $setting4->setSettingValue("{\"show\": true, \"required\": true}");

 

It was working for a long time (up until about a month ago) without needing the above snippet of code when all of a sudden it stopped working.

Adding the code fixes the problem.

 

BertQ