Reply
Highlighted
Contributor
Posts: 18
Registered: ‎05-18-2018

Webhook ping failed, but my endpoint is working

[ Edited ]

Hello,

 

I have an endpoint set up on my end to receive JSON from Authorize.net's webhooks. I tested the endpoint using Postman to verify that it's up and running. I have even sent it a sample from your documentation, and I was able to pull in the JSON into a Java object without any issues. However, when I try to use "Test Webhook", I get "Error: The ping operation failed. This could be due to connectivity issues, invalid url or server downtime. Check the url details for the webhook and try again." What could possibly be the issue? My endpoint is using an IP address and a port of 9443, and it is expecting https.

 

 

Contributor
Posts: 18
Registered: ‎05-18-2018

Re: Webhook ping failed, but my endpoint is working

[ Edited ]

Also, I have it returning a response status code of OK (200).

Contributor
Posts: 18
Registered: ‎05-18-2018

Re: Webhook ping failed, but my endpoint is working

I also tested over http using port 9080 in Postman, and that works, too. But http and port 9080 did not work when testing the webhook.

Posts: 333
Kudos: 73
Solutions: 36
Registered: ‎03-13-2017

Re: Webhook ping failed, but my endpoint is working

Is your url available  externally over the internet ?

 

Try using the url from http://webhookinbox.com/ and check if you are getting the notifications . 

 

 





Send feedback at developer_feedback@authorize.net
Contributor
Posts: 18
Registered: ‎05-18-2018

Re: Webhook ping failed, but my endpoint is working

Hi Anurag,

 

Yes, the URL is available over the Internet. I had a coworker access it from the office (I am running this at home until we can get some firewall issues sorted out).  I can message you the URL if you want (I do not want to post it here). I will webhookinbox a try.

Contributor
Posts: 18
Registered: ‎05-18-2018

Re: Webhook ping failed, but my endpoint is working

I tried using webhookinbox, and I can see the message from Authorize.net.

Member
Posts: 3
Registered: ‎06-28-2018

Re: Webhook ping failed, but my endpoint is working

Hello, were you able to resolve this? i to have the same issue i run a custom port on my end point and it does not work. 

 

I'm having to route it through a different URL then sent the request back to my original server via CURL. 

 

 

Any ideas woudl be helpful thanks!

Member
Posts: 2
Registered: ‎08-27-2021

Re: Webhook ping failed, but my endpoint is working

Facing the same issue any solution, please.