Reply
Contributor
Posts: 48
Registered: ‎06-08-2011
Accepted Solution

CIM hosted form returns null token

[ Edited ]

Hi,

I'm using the GetHostedProfilePage web service method to retrieve a token. When I reference an account with an existing card, the token value is null. However, when I create a new profile and retrieve a token using the same code, I get a token back.

 

Below is my code:

 

token = GetHostedProfilePage(ProfileId);

  public string GetHostedProfilePage(long profileId)
        {          
            var validationMode = new SettingType
            {
                settingName = "hostedProfileValidationMode",
                settingValue = isProd ? "liveMode" : "testMode"
            };

            var settings = new[] { validationMode};
            var response = Service.GetHostedProfilePage(MerchantAuthentication, profileId, settings);          
            return response.token;
        }

 


Accepted Solutions
Solution
Accepted by topic author martin1b
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM hosted form returns null token

Not the web traffic the response.token, the response should have more then just the token properties

View solution in original post


All Replies
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM hosted form returns null token

can you read the response message? might be there an error?

Highlighted
Contributor
Posts: 48
Registered: ‎06-08-2011

Re: CIM hosted form returns null token

Did a fiddler capture and don't see anything obvious. Everything looks like 200/OKs .
Solution
Accepted by topic author martin1b
‎08-21-2015 01:58 AM
Expert
Posts: 4,525
Registered: ‎03-08-2010

Re: CIM hosted form returns null token

Not the web traffic the response.token, the response should have more then just the token properties

Contributor
Posts: 48
Registered: ‎06-08-2011

Re: CIM hosted form returns null token

Ah! Yes, I see it. There are messages. Thanks!!